Note: The StagesPower app requires a compatible Android device running Android 4.3 or newer. If your device shows up as not compatible, you may need to update your operating system to the latest version to use the StagesPower app. Please check your device under Settings>More>About Device>Software Update to see if you are able to update.

Link to: Stages Power - Android App Link


StagesPower in the Google Play store



SC-E48.1